package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\ban\b`)
var str = `Elephant an animal`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}