#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$"
Local $sString = " John Smith, Jr." & @CRLF & _
"Winn Thomas" & @CRLF & _
" Mary 3llen Jones " & @CRLF & _
"Clyde Franklin, III" & @CRLF & _
"wallace firt, the" & @CRLF & _
"wimbobimbo ff , VIVIVVVVIIIVIIVVI" & @CRLF & _
"s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr."
Local $sSubst = "Ye Tar Oo Yetaroo3 Uyetar Goffery "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)