use strict;
my $str = ' John Smith, Jr.
Winn Thomas
Mary 3llen Jones
Clyde Franklin, III
wallace firt, the
wimbobimbo ff , VIVIVVVVIIIVIIVVI
s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.';
my $regex = qr/^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$/mp;
my $subst = 'Ye Tar Oo Yetaroo3 Uyetar Goffery ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";