import re
regex = re.compile(r"^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$", flags=re.MULTILINE)
test_str = (" John Smith, Jr.\n"
"Winn Thomas\n"
" Mary 3llen Jones \n"
"Clyde Franklin, III\n"
"wallace firt, the\n"
"wimbobimbo ff , VIVIVVVVIIIVIIVVI\n"
"s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.")
subst = "Ye Tar Oo Yetaroo3 Uyetar Goffery "
result = regex.sub(subst, test_str)
if result:
print(result)