import Foundation
let pattern = #"^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
John Smith, Jr.
Winn Thomas
Mary 3llen Jones
Clyde Franklin, III
wallace firt, the
wimbobimbo ff , VIVIVVVVIIIVIIVVI
s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Ye Tar Oo Yetaroo3 Uyetar Goffery "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)