$re = '/#/i';
$str = ' #somecomment
# some comment
"#not a commnet" #another comment
\'#not a comment\'
jquery_code = "$(\'#some-identifier\')[0].click()"#yet a comment, but the identifier :(
jquery_code = \'$("#some-identifier")[0].click()\'
# just another comment
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);