Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
itemVar":{"value":"([\s\S]*?)"}
/
gm
Input 1
1
New
[{"$type":"DeclareGlobalTypePropertyBlock","x":92,"y":88,"parts":{"itemVar":{"value":"GUID"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"SelectedModuleGUID"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"Id"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"Label"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"isInfiltration"},"type":{"value":"boolean"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"UnderdrainSize"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"UnderdrainInvert"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"ModuleLayoutType"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"RequiredSurfaceArea"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"AcualSurfaceArea"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"DesiredWidth"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"TotalRequiredLength"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"EstimatedModuleNumber"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"ModuleWidth"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"ModuleLength"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"arrModuleLengths"},"type":{"value":"number[]"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"ModuleHeight"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"ModuleKeys"},"type":{"value":"text[]"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"extentsXMax"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"extentsXMin"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"extentsYMax"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"extentsYMin"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"SystemDesignation"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"isValid"},"type":{"value":"boolean"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"hasInvalidModule"},"type":{"value":"boolean"}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}]