# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<name>[a-zA-Z0-9]*(?<!constructor)(?<!if)\s*)(?<arguments>\([^()\r]*\))(?<body>\s*{((?:[^{}](?!return))*(?:\g<body>)?)+})/$1$2: void$3/gm;t' <<< "function test(arg1: test, arg2: test) {
{{{{{}}}}}
}"