use strict;
my $str = 'function test(arg1: test, arg2: test) {
{{{{{}}}}}
}';
my $regex = qr/(?<name>[a-zA-Z0-9]*(?<!constructor)(?<!if)\s*)(?<arguments>\([^()\r]*\))(?<body>\s*{((?:[^{}](?!return))*(?:\g<body>)?)+})/mp;
my $subst = '$1$2: void$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";