package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[{youtube ]{9}.+[}]{1}`)
var str = `yyyy{{{ bb_}
{{ tbeby@#$} fafasdfasd}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}