const regex = /^(?!\*\*Bewerbung von .*:\*\*\n\n\*Name:\* .*\n\*MC-Name:\* .*\n\*Alter:\* .*\n\*Aufgabe:\* .*\n\*Vorteile:\* .*\n\*Gründe:\* .*)([\w\W]+)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\*\\*Bewerbung von .*:\\*\\*\\n\\n\\*Name:\\* .*\\n\\*MC-Name:\\* .*\\n\\*Alter:\\* .*\\n\\*Aufgabe:\\* .*\\n\\*Vorteile:\\* .*\\n\\*Gründe:\\* .*)([\\w\\W]+)$', 'g')
const str = `**Bewerbung von :**
*Name:*
*MC-Name:*
*Alter: Missing a \`*\` here, plan foiled!
*Aufgabe:*
*Vorteile:*
*Gründe:* `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}