#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=^[^\d]*\d[^\d]*\d[^\d]*$)(?=.*[a-z])(?=.*[A-Z]).{8,}$"
Local $sString = "123456789" & @CRLF & _
"abcdefghi" & @CRLF & _
"ABCDEFGHI" & @CRLF & _
"abcdABC12" & @CRLF & _
"abcdABC121" & @CRLF & _
".12nabdh#A" & @CRLF & _
"Abc4k9h2L" & @CRLF & _
"Abc4k9hL+" & @CRLF & _
"" & @CRLF & _
"Abc4l@s$kl4 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")