using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=^[^\d]*\d[^\d]*\d[^\d]*$)(?=.*[a-z])(?=.*[A-Z]).{8,}$";
string input = @"123456789
abcdefghi
ABCDEFGHI
abcdABC12
abcdABC121
.12nabdh#A
Abc4k9h2L
Abc4k9hL+
Abc4l@s$kl4 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}