import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=^[^\\d]*\\d[^\\d]*\\d[^\\d]*$)(?=.*[a-z])(?=.*[A-Z]).{8,}$";
final String string = "123456789\n"
+ "abcdefghi\n"
+ "ABCDEFGHI\n"
+ "abcdABC12\n"
+ "abcdABC121\n"
+ ".12nabdh#A\n"
+ "Abc4k9h2L\n"
+ "Abc4k9hL+\n\n"
+ "Abc4l@s$kl4 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}