re = /^(?=^[^\d]*\d[^\d]*\d[^\d]*$)(?=.*[a-z])(?=.*[A-Z]).{8,}$/m
str = '123456789
abcdefghi
ABCDEFGHI
abcdABC12
abcdABC121
.12nabdh#A
Abc4k9h2L
Abc4k9hL+
Abc4l@s$kl4 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end