// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xm)^
(?=[^a-z\n]*[a-z]) # ensure one lower case letter
(?=[^A-Z\n]*[A-Z]) # ensure one upper case letter
(?=[^\d\n]*\d) # ensure a digit
(?=[^!@?\n]*[!@?]) # special chars
.{10,} # at least 10 characters long
$").unwrap();
let string = "1234567890
AAAAAAAAAA
ABCDEFG123@a
aaaaa
@@@@@
abdgdgdh45FG@";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}