$re = '/(?<!^\h)(?<!^\h\h)(?<!^\h\h\h)(?<!\h\h\h\h)\b(\d{1,3})\.(\d{1,3})\.(\d{1,3})\.(\d{1,3})\b/m';
$str = '
1.blah
1.1 blah blah
1.1.1 blah blah blah my ip address is 192.168.1.1
1.1.1.1 blah blah blah blah (DLP thinks this is an IP Address and block the document)
On the 1. January the profit rate was 3.5 %, and by article 3.1.4. in the agreement we sent that information to 127.0.0.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);