#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((0[1-9])|[^0]\d):)?[0-5]\d:[0-5]\d$"
Local $sString = "04:05" & @CRLF & _
"50:20" & @CRLF & _
"00:59" & @CRLF & _
"00:60" & @CRLF & _
"88:40" & @CRLF & _
"00:02:03" & @CRLF & _
"01:02:03" & @CRLF & _
"88:00:50" & @CRLF & _
"00:00:45" & @CRLF & _
"02:77:35" & @CRLF & _
"00:04:80"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")