import re
regex = re.compile(r"(((0[1-9])|[^0]\d):)?[0-5]\d:[0-5]\d$", flags=re.MULTILINE)
test_str = ("04:05\n"
"50:20\n"
"00:59\n"
"00:60\n"
"88:40\n"
"00:02:03\n"
"01:02:03\n"
"88:00:50\n"
"00:00:45\n"
"02:77:35\n"
"00:04:80")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")