re = /(?<={)([\s\S]+?)(?=})/
str = '{0}{5}
{1}{dfdf}
{2}{пара, пара п.а пара&па®}
{3}{dfdf!}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end