# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^,+|,+$//gm;t' <<< ",,,,,,,12345
12345,1345,1354
123,,,,,,
12345,
,12354"