#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^,+|,+$"
Local $sString = ",,,,,,,12345" & @CRLF & _
"12345,1345,1354" & @CRLF & _
"123,,,,,," & @CRLF & _
"12345," & @CRLF & _
",12354"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)