package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^,+|,+$`)
var str = `,,,,,,,12345
12345,1345,1354
123,,,,,,
12345,
,12354`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}