// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<\/time>\s\s\s<a href=\"(.*?)\" "#).unwrap();
let string = "lass=\"js-thumb-slider playlist_list\">
<noscript>
<li>
<time datetime=\"2018-03-18T00:09:28.000+0000\"></time>
<a href=\"https://www.example.com/\" title=\">dsfsdf</a>
</li>
<li>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}