$re = '/\((?![^()]*\bBAD\b[^()]*\))[^()]*\)/m';
$str = '(Today is a blue day) (Today is a good day) (Today is a BAD day) (Today is a green day) (Today is a blue day)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);