re = /^ns\-\d{0,4}\.awsdns\-\d\d\.(org|co\.uk|net|com)$/m
str = 'ns-1354.awsdns-41.org
ns-1658.awsdns-15.co.uk
ns-52.awsdns-06.com
ns-807.awsdns-36.net
ns-1658.awsdns-15.co.uk
ns-52.awsdns-06.com
ns-807.awsdns-36.net
ns-1354.awsdns-41.org
ns.domaincontrol.com
ns-1.awsdns-36.net
ns.google.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end