package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]+[0-9]*[_.-]?[a-z0-9]+$`)
var str = `gabriel.perezguerra`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}