#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bPrint\sName:\n(?!Print\sName)(?'guarantor1'[a-zA-Z\s',.&\d\--]+?)(?=(?:\s\1)?$)"
Local $sString = "Borrower: Guarantor:" & @CRLF & _
"{{0_SH}} By: {{1_SH}} (seal)" & @CRLF & _
"By: (seal)" & @CRLF & _
"Print Name:" & @CRLF & _
"Print Name:" & @CRLF & _
"Phillip Moore Phillip Moore" & @CRLF & _
"Date: {{1_DH}}" & @CRLF & _
"2/23/2022" & @CRLF & _
"Title: Owner" & @CRLF & _
"Date: {{0_DH}}" & @CRLF & _
"2/23/2022" & @CRLF & _
"12 of 12 (LOC 2020) Borrower Initials {{0_IH}}" & @CRLF & _
"" & @CRLF & _
"Borrower: Guarantor:" & @CRLF & _
"{{0_SH}} By: {{1_SH}} (seal)" & @CRLF & _
"By: (seal)" & @CRLF & _
"Print Name:" & @CRLF & _
"Print Name:" & @CRLF & _
"Phillip test Moore Phillip test Moore" & @CRLF & _
"Date: {{1_DH}}" & @CRLF & _
"2/23/2022" & @CRLF & _
"Title: Owner" & @CRLF & _
"Date: {{0_DH}}" & @CRLF & _
"2/23/2022" & @CRLF & _
"12 of 12 (LOC 2020) Borrower Initials {{0_IH}}" & @CRLF & _
"" & @CRLF & _
"Borrower: Guarantor:" & @CRLF & _
"{{0_SH}} By: {{1_SH}} (seal)" & @CRLF & _
"By: (seal)" & @CRLF & _
"Print Name:" & @CRLF & _
"Print Name:" & @CRLF & _
"Phillip test Moore" & @CRLF & _
"Date: {{1_DH}}" & @CRLF & _
"2/23/2022" & @CRLF & _
"Title: Owner" & @CRLF & _
"Date: {{0_DH}}" & @CRLF & _
"2/23/2022" & @CRLF & _
"12 of 12 (LOC 2020) Borrower Initials {{0_IH}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")