# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bPrint\sName:\n(?!Print\sName)(?'guarantor1'[a-zA-Z\s',.&\d\--]+?)(?=(?:\s\1)?$)"
test_str = ("Borrower: Guarantor:\n"
"{{0_SH}} By: {{1_SH}} (seal)\n"
"By: (seal)\n"
"Print Name:\n"
"Print Name:\n"
"Phillip Moore Phillip Moore\n"
"Date: {{1_DH}}\n"
"2/23/2022\n"
"Title: Owner\n"
"Date: {{0_DH}}\n"
"2/23/2022\n"
"12 of 12 (LOC 2020) Borrower Initials {{0_IH}}\n\n"
"Borrower: Guarantor:\n"
"{{0_SH}} By: {{1_SH}} (seal)\n"
"By: (seal)\n"
"Print Name:\n"
"Print Name:\n"
"Phillip test Moore Phillip test Moore\n"
"Date: {{1_DH}}\n"
"2/23/2022\n"
"Title: Owner\n"
"Date: {{0_DH}}\n"
"2/23/2022\n"
"12 of 12 (LOC 2020) Borrower Initials {{0_IH}}\n\n"
"Borrower: Guarantor:\n"
"{{0_SH}} By: {{1_SH}} (seal)\n"
"By: (seal)\n"
"Print Name:\n"
"Print Name:\n"
"Phillip test Moore\n"
"Date: {{1_DH}}\n"
"2/23/2022\n"
"Title: Owner\n"
"Date: {{0_DH}}\n"
"2/23/2022\n"
"12 of 12 (LOC 2020) Borrower Initials {{0_IH}}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.