# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\\)\\{1,2}n/<br>/g;t' <<< "this is a sample\\nstring\\\\ncontaining\nall cases\n\\n\n\\\n!
this is a sample<br>string\\\\ncontaining<br>all cases<br><br><br>!"