using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)\\{1,2}n";
string substitution = @"<br>";
string input = @"this is a sample\\nstring\\\\ncontaining\nall cases\n\\n\n\\\n!
this is a sample<br>string\\\\ncontaining<br>all cases<br><br><br>!";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}