$re = '/[0-9]+|[a-zA-Z]+/';
$str = 'TU111 1998 SUMMER
TU-232 SU 1999
TU232 1999 SUMMER';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);