$re = '/^\d+(?:,(?:(\[(?:[^][]++|\g<1>)*])|\d+))?$/m';
$str = '1,[]
1,[0,0,0,[]]
1,[0,0,0,0,0,[]]
1,1
1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);