package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`idIwant.*?(\d+)`)
var str = `{},\"employees\":{},\"idIwant\":{\"2545\":{\"attributes\":{\"offset\":9855,`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}