$re = '/^(?!\d{5,}).*?$/m';
$str = '12345testing123asd
1234testing1234
testing12345
testing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);