import Foundation
let pattern = #" \K(?:alt|title|src|href)=["']?[^>"']+["']?>??"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<anytag aa="att1">DESC 1</anytag>
<item aa="att2">DESC 2</item>
<anytag bb="att3">DESC 3</anytag>
<anytag alt=att4>DESC 4</anytag>
<anytag src="att5">DESC 5</anytag>
<anytag src="att6">DESC 6</anytag>
<anytag src='att7'>DESC 7</anytag>
<anytag src='att8'>DESC 8</anytag>
<anytag href="att9" title="title1">DESC 9</anytag>
<anytag blabla="att10">DESC 10</anytag>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)