import Foundation
let pattern = #"^[putdn]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA_A_N10_packageName
p_SPEC.operation.Delta_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.Delta_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.Delta_v13.0_20181110_D1.zip
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)