using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"public (\w*?) ([A-Z])(\w*?) { get; set; }";
string substitution = @"\L$2\E$3: $1;";
string input = @" public string TenLop { get; set; }
public int TongSoHocSinh { get; set; }
public int SoNam { get; set; }
public int SoNu { get; set; }
public int SoNhoHon18Th { get; set; }
public int SoTu18ThDen3T { get; set; }
public int SoTu3TDen4T { get; set; }
public int SoTu4TDen5T { get; set; }
public int SoLonHon5T { get; set; }
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}