# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\P{L}a-z]+(\.[^\P{L}a-z]+)+//uig;t' <<< " abcd.com 普遍接受测试.世界 ya.ru домен.рф abcd.com "