use strict;
my $str = ' abcd.com 普遍接受测试.世界 ya.ru домен.рф abcd.com ';
my $regex = qr/[^\P{L}a-z]+(\.[^\P{L}a-z]+)+/uip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";