// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ui)[^\P{L}a-z]+(\.[^\P{L}a-z]+)+").unwrap();
let string = " abcd.com 普遍接受测试.世界 ya.ru домен.рф abcd.com ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}