import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?<!])((#(?!#)(.*?)#(?!#))|(##(?!#)(.*?)##))";
final String string = "The text [.underline]#underline me# is underlined. +\n"
+ "The text [.line-through]#aaa# ist durchgestrichen.\n\n"
+ "text #just highlight#, normal tex#t#fg#f#gfg \n\n"
+ "#ffsfsdf fdsfsd#\n\n"
+ "TODO: wrong marking\n\n"
+ "The *[red]##c##[green]##o##[purple]##l##[fuchsia]##o##[blue]##r##* brings contrast to the text, making it easier to read.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}