$re = '/(?m)(?<!])((#(?!#)(.*?)#(?!#))|(##(?!#)(.*?)##))/m';
$str = 'The text [.underline]#underline me# is underlined. +
The text [.line-through]#aaa# ist durchgestrichen.
text #just highlight#, normal tex#t#fg#f#gfg
#ffsfsdf fdsfsd#
TODO: wrong marking
The *[red]##c##[green]##o##[purple]##l##[fuchsia]##o##[blue]##r##* brings contrast to the text, making it easier to read.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);