# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(?<!])((#(?!#)(.*?)#(?!#))|(##(?!#)(.*?)##))"
test_str = ("The text [.underline]#underline me# is underlined. +\n"
"The text [.line-through]#aaa# ist durchgestrichen.\n\n"
"text #just highlight#, normal tex#t#fg#f#gfg \n\n"
"#ffsfsdf fdsfsd#\n\n"
"TODO: wrong marking\n\n"
"The *[red]##c##[green]##o##[purple]##l##[fuchsia]##o##[blue]##r##* brings contrast to the text, making it easier to read.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.