import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d*(min-width|max-width):\\s*(\\d+\\s?)(px)";
final String string = "all and (min-width: 640px) and (max-width: 1023px)\n"
+ "min-width:640px\n"
+ "@media screen and (max-width: 699px) and (min-width: 520px)\n"
+ "media screen and (min-width: 1001px)\n"
+ "@media screen and (max-width: 699px) and (min-width: 520px), (min-width: 1151px)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}