use strict;
my $str = 'all and (min-width: 640px) and (max-width: 1023px)
min-width:640px
@media screen and (max-width: 699px) and (min-width: 520px)
media screen and (min-width: 1001px)
@media screen and (max-width: 699px) and (min-width: 520px), (min-width: 1151px)';
my $regex = qr/\d*(min-width|max-width):\s*(\d+\s?)(px)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}