# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d*(min-width|max-width):\s*(\d+\s?)(px)"
test_str = ("all and (min-width: 640px) and (max-width: 1023px)\n"
"min-width:640px\n"
"@media screen and (max-width: 699px) and (min-width: 520px)\n"
"media screen and (min-width: 1001px)\n"
"@media screen and (max-width: 699px) and (min-width: 520px), (min-width: 1151px)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.