// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d*(min-width|max-width):\s*(\d+\s?)(px)").unwrap();
let string = "all and (min-width: 640px) and (max-width: 1023px)
min-width:640px
@media screen and (max-width: 699px) and (min-width: 520px)
media screen and (min-width: 1001px)
@media screen and (max-width: 699px) and (min-width: 520px), (min-width: 1151px)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}