$re = '/(?:begin|\G(?!^))(?:(?!end)\D)+\K\d+/';
$str = '11
a
b
13
begin
t
899
y
50
f
end
91
h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);