package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<version>[^-]*)(-*(?<compatibility>.*))?$`)
var str = `12.6.2-alpine
12.6.2
12.6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}